업데이트내용

패치를 통해 설치오류가 해결되었다는 공지가 올라왔으나 아직도 지속적으로 설치가 안 되는 분들이 계시는 것으로 보아 완전히 문제가 해결되지 않은 것으로 보인다. 만일 KoNLP설치 이슈가 있다면 library폴더에 제대로 KoNLP폴더가 생기는지 확인해야 한다. 만약 KoNLP폴더가 아예 생기지도 않는다면 아래 링크해둔 전체 폴더를 library폴더에 압축해제 하여 사용하길 바란다. 혹은 CRAN서버에 이전 버전 또는 최신 버전의 KoNLP tar.gz파일이 있으므로 수동 설치를 시도해볼 수 있다.

CRAN KoNLP Archive 링크

1.코드를 통한 tar.gz source 설치

install.packages(".../path/to/package.tar.gz", type="source", repos=NULL)

2.R-studio기능을 통한 tar.gz source 설치

Rstudio – Tool – install packages 클릭 – install from 옵션에서 package archive file 선택 – Browse클릭해서 tar.gz 파일 선택 – library 경로 선택 – Install 버튼 클릭

추신. 필자는 현재 R을 사용하지 않는 중이라 여러 기기에서의 테스트가 어렵습니다. 설치가 안 되는 기기가 있다면 제게 사용하시는 운영체제, 버전을 알려주시기 바랍니다. Mac컴퓨터는 대응이 어렵습니다. 감사합니다.

원본내용

2020년 1월 15일부터 Central Repository 중 하나인 repo1.maven.org가 더이상 HTTP연결을 지원하지 않게 되면서 패키지 필요 파일을 maven에 요청하는 R패키지들이 제대로 설치되지 않는 문제가 보고되고 있다.

거두절미하고, 그러한 이유로 R패키지 중 가장 사랑 받고 있는 KoNLP가 신규 설치 혹은 업데이트 설치시 제대로 설치가 되지 않는 오류를 보이고 있다. 문제는 KoNLP github에 가보면 업데이트가 3년 전에 있은 후로 업데이트가 없다는 점인데 아무래도 해결되는 데에 시일이 걸릴 것으로 예상된다.

따라서 해당 문제를 해결하기 위해서는 필요한 파일을 직접 다운로드 하여 패키지 폴더에 넣어주어야 한다.

다운로드 링크

위 링크를 클릭하여 java.zip파일을 받고 압축을 풀어준다. 압축이 해제된 폴더를 에러메시지가 말하는 위치에 복사 붙여넣기하고 파일을 덮어씌우면 KoNLP패키지가 작동한다.

예를 들어 아래와 같은 오류 메시지가 뜬다면 /data/gannet/ripley/R/test-clang/00LOCK-KoNLP/00new/KoNLP 경로에 있는 java폴더와 다운 받은 java폴더를 바꿔주거나 덮어쓰기 하면 된다.

Fail to install scala-library-2.11.8.jar. Recommand to install library
manually in /data/gannet/ripley/R/test-clang/00LOCK-KoNLP/00new/KoNLP/java

추가

scala-library-2.11.8.jar 문제 뿐만 아니라 다른 데에서도 종합적으로 문제가 생기는 것으로 보인다. KoNLP패키지가 정상작동하는 컴퓨터에서 패키지 폴더를 통째로 압축해둔 파일을 공유하니 문제가 생기는 파일에 복붙하거나 없는 파일을 보충해주면 될 것 같다. (추출한 컴퓨터의 사양은 윈도우10 64비트버전)

KoNLP전체폴더 다운로드


42개의 댓글

잉무 · 2020-01-22 5:16 오후

와 어쩐지 “Fail to install scala-library-2.11.8.jar.” 이 메시지가 떠서 보니까 이 파일 자체가 폴더에 없더라구요.. konlp를 수십번 재설치 하면서 계속 이 문제 때문에 애먹었는데 드디어 해결되었습니다..ㅠㅠㅠㅠ 감사합니다

    Gugu · 2020-01-22 5:21 오후

    지인 컴퓨터에 패키지를 설치하다가 우연히 발견한 오류인데 사안이 심해서 빨리 공유를 해야겠더라고요. 도움이 되었다니 다행입니다.

황금돼지 · 2020-01-23 10:30 오전

이 난국을 어찌 해결해야 할지??…ㅎㅎ
이런 정보는 정말 고맙기 그지 없습니다.

    Gugu · 2020-01-23 4:52 오후

    도움이 되었다니 다행입니다. 패키지 개발자분께 연락 드리니 개인적인 사정으로 2월까지 수정이 어렵다고 하십니다. 불편하더라도 이 방법을 굳이 사용해야겠네요

베니 · 2020-01-24 5:27 오전

올려주신 내용 많이 도움이 됐습니다. 감사합니다. 저도 패키지 개발자분 사이트에 가니 2월까지 바쁘시다는 글을 보고 고민중에 있습니다.. 혹시 Gugu님께서 R에 대해 지식이 있는분인거 같아 하나 더 여쭤봐도 되는지요? Konlp, rJava는 성공적으로 설치는 됐으나 SimplePos22를 사용하여 형태소 분석을 하려고 하니 There were 50 or more warnings (use warnings() to see the first 50)와 메시지와 함께 In value[[3L]](cond) : can’t processing : [분석하고자한 문장들]이 나옵니다. SimplePos09, extractNoun 모두 동일한 메시지가 나옵니다. 같은 방식으로 몇주전까지 잘 됐었는데 어느순간부터 되지 않습니다 ㅠㅠ(코드를 바꾸진 않았습니다.) 혹시 이런 경우 있으신지요?

Gugu · 2020-01-24 8:01 오전

제가 올려드린 java폴더 내 파일 전체를 패키지 내 java폴더 파일과 교체해주면 일단 정상 작동해야됩니다. 이미 잘 쓰고 있던 패키지라도 install.package로 업데이트 하면 오류가 생길 수 있습니다. 그래도 안 된다면 일단 KoNLP패키지 폴더를 지우고 다시 인스톨 후에 java폴더 파일을 교체해주십시오.

베니 · 2020-01-24 5:08 오후

빠른 답변 감사합니다. 말씀하신대로 KoNLP의 문제인거 같습니다. 그리고 잘되다가 안되는거 보니 업데이터 문제도 맞는거 같구요.. 그런데 조언을 해주신대로 해보았으나 에러가 해결되지 못했습니다..
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
at java.lang.String.substring(String.java:1967)
at kr.ac.kaist.swrc.jhannanum.plugin.SupplementPlugin.PlainTextProcessor.SentenceSegmentor2.
SentenceSegmentor2.doProcess(SentenceSegmentor2.scala:68)
at kr.ac.kaist.swrc.jhannanum.hannanum.
Workflow.analyzeInSingleThread(Workflow.java:835)
at kr.ac.kaist.swrc.jhannanum.hannanum.
Workflow.analyze(Workflow.java:549)
at kr.pe.freesearch.jhannanum.comm.
HannanumInterface.SimplePos22(HannanumInterface.java:279)

위와 같은 에러를 내뱉었는데, 혹시 이 메시지를 어떻게 대처하는지 아시는지요?
아무리 구글링 해보아도 해결하기 어려웠습니다. substring도 확장해보고..JAVA_HOME 경로도 다시 지정해보아도 어렵네요.. 혹시 조언 가능한지요.

    Gugu · 2020-01-24 5:32 오후

    제가 밖에 있어서 정확하게 살펴볼 수는 없지만 제가 살펴보니 inst폴더 안에 java폴더가 또 있는데 jhannanum.jar 파일이 제대로 작동을 안 하거나 없을 수 있습니다. 설이라… 컴퓨터도 없어서 제대로 확인을 못하는 점 양해바랍니다.

      베니 · 2020-01-27 8:02 오후

      jhannanum.jar 파일이 있었지만 Konlp 삭제하고 다시 깔아도 안되고 올려주신 java내 파일도 다시 깔아봐도 안됩니다.. java 실행파일이 문제가 있거든 konlp 시행시 뭔가 충돌하는걸까요, 참 어렵습니다 ㅠㅠ

    Gugu · 2020-01-27 8:05 오후

    제가 조만간 작동이 잘 되는 KoNLP 패키지 전체 파일을 올려드리겠습니다.

      베니 · 2020-01-31 4:11 오후

      감사합니다!

뽀요티비 · 2020-01-26 6:40 오후

저의 경우는 경고메시지가 ‘에러: 네임스페이스 ‘rlang’ 0.4.0는 이미 로드되었으나 >= 0.4.1가 필요합니다’ 라고 뜨네요… 지시대로 rlang 패키지를 따로 설치해도 extractNoun이 제대로 작동이 안되고요! 답답합니다

    Gugu · 2020-01-29 11:44 오전

    KoNLP패키지 전체 파일을 올렸습니다. 누락된 파일이 있다면 해당 파일로 교체해주시기 바랍니다. 제가 시간이 별로 없어서 하나씩 뜯어보지 못하는 게 좀 그렇네요.

슬이 · 2020-01-31 3:36 오후

아니 진짜 당신은 천사이십니까? 이틀 내내 고민했는데…정말 감사드려요. 저도 이렇게 도움되는 사람을 자라나겠습니다!!!

동동 · 2020-02-11 4:42 오전

드디어 해결했습니다 ㅠㅠ 감사합니다!!!

감사감사합니다 · 2020-02-13 1:49 오후

정말 감사해요 며칠간 뭐가 문제인지 모르고 해매고 있었는데, 이 글 보고 해결했습니다. 감사합니다~

초보자 · 2020-02-15 8:44 오후

안녕하세요 같은 문제를 겪고 있는 R입문자입니다.ㅠㅜ 혹시 이런 에러가 뜨는데 왜 그런지 알 수 있을까요?ㅠㅜ

WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

https://cran.rstudio.com/bin/windows/Rtools/
Installing package into ‘C:/Users/Jungwook/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
Warning in install.packages :
package ‘KoNLP’ is not available (for R version 3.6.2)
Warning messages:
1: In dir.create(tempPath, recursive = TRUE) :
cannot create dir ‘C:\’, reason ‘Permission denied’
2: In readLines(file, skipNul = TRUE) :
cannot open compressed file ‘C:/Users/Jungwook/Documents/R/win-library/3.6/rlang/DESCRIPTION’, probable reason ‘No such file or directory’

질의 · 2020-03-02 3:43 오후

> install.packages(“KoNLP”, lib=”C:/R-3.6.3/library”)
Warning in install.packages :
package ‘KoNLP’ is not available (for R version 3.6.3)

오류 해결법 문의드립니다…..

    Gugu · 2020-03-02 3:53 오후

    안녕하세요, install.packages(“KoNLP”) 명령어로 시도하신 건가요? 아니면 lib폴더를 별도로 지정해주신 건 가요? lib폴더 지정 없이 한번 설치해보시고 안 되면 페이지에 올려놓은 전체 폴더를 다운로드 하신 후 lib폴더에 압축 풀어서 둬주시면 library(KoNLP)로 불러오실 수 있으실 겁니다(64비트 윈도우10)

질의 · 2020-03-02 9:30 오후

> install.packages(“KoNLP”)하면,

Warning in install.packages :
package ‘KoNLP’ is not available (for R version 3.6.3)
이렇게 뜨는데 어떻게 해야하는지 문의드립니다… 감사합니다..ㅠㅠ

    Gugu · 2020-03-05 11:17 오전

    윈도우에서 R을 쓰고 계시다면 제가 올려드린 전체 폴더를 라이브러리 폴더에 압축해제 하여 옮겨주세요 그 다음 library명령어로 한번 시도해주시기 바랍니다.

질문 · 2020-03-02 9:46 오후

글 잘 읽고 가요! 저는 install.packages(‘KoNLP’) 하니까 ‘사용가능하지 않습니다. 그 이유는 for R version 3.6.0 입니다’ 이런식으로 뜨네요..ㅜ rJava까지 다 설치해놨습니다.. 버전문제는 아닌 것같은데 구글링해도 답이 안나오네요…ㅠㅠ

    Gugu · 2020-03-05 11:17 오전

    윈도우에서 R을 쓰고 계시다면 제가 올려드린 전체 폴더를 라이브러리 폴더에 압축해제 하여 옮겨주세요 그 다음 library명령어로 한번 시도해주시기 바랍니다.

Shampoo · 2020-03-10 9:09 오후

저는 Mac에서 R을 쓰는데 동일하게 KoNLP가 없다고 나오네요. Mac용도 설치하는 파일과 방법을 알려주시면 감사드리겠습니다.

    Gugu · 2020-03-11 9:14 오전

    제 주변에 Mac을 쓰시는 분이 없어서 테스트를 못하고 있습니다. 죄송합니다. 혹시 동료분들 중에 Mac 사용자가 있고 KoNLP를 잘 사용하시는 분이 계시면 Library폴더 안에 있는 KoNLP 폴더를 통째로 옮겨서 사용해보시면 좋을 것 같습니다.

R언어초보자 · 2020-03-11 2:43 오후

> install.packages(“KoNLP”)
Warning in install.packages :
package ‘KoNLP’ is not available (for R version 3.6.2)
> library(KoNLP)
Error in library(KoNLP) : ‘KoNLP’이라고 불리는 패키지가 없습니다
=============================================================
이렇게 떠서 댓글에 올려져 있는대로
올려주신 소중한 압축폴더를 library폴더에 압축해제 하고 library명령어로만 실행 해봤는데
안되네요..ㅠㅠㅠㅠㅠ

    Gugu · 2020-03-11 3:07 오후

    – KoNLP폴더 안에 바로 data폴더가 있는지 확인해주세요. (KoNLP폴더가 또 있으면 안 됩니다)
    – 패키지 library 폴더가 맞는지, 경로가 맞는지 확인해주세요.
    – 윈도우10 64bit가 맞는지 확인해주세요.

    그럼에도 불구하고 진행이 안 되면 다시 댓글 달아주세요. 제가 R을 사용하지 않은지가 꽤 돼서, 테스트를 하기가 어렵습니다.

지민솜사탕 · 2020-04-14 10:43 오전

제가 웬만하면 댓글을 안쓰는데 이틀 내내 애먹었던게 바로 해결되서 너무 기뻐요
구글링으로 여기저기 찾아보고 했는데 올려주신 KoNLP, Java파일 다운받고 재인스톨하니까 바로 해결되네요.
KoNLP는 java version 8이하로 받으셔야하고 나머지 KoNLP 인스톨 수동으로 해도 라이브러리 안불러지거나 extractNoun이 안되는건 여기서 올려주신 파일 받아서 덮어쓰면 되요!!! 자주 들려서 많이 배우겠습니다. 정말 감사해요!!!

    Gugu · 2020-04-14 11:29 오전

    도움이 되었다니 다행입니다 🙂

신한수 · 2020-04-19 7:44 오전

> install.packages(“KoNLP”)
Warning in install.packages :
package ‘KoNLP’ is not available (for R version 3.6.2)

– KoNLP폴더 안에 바로 data폴더가 있는지 확인해주세요. (KoNLP폴더가 또 있으면 안 됩니다)
data, doc, help, html, java, Meta, R, DESCRIPTION, INDEX, MD5, NAMESPACE, NEWS 이렇게 있습니다.
– 패키지 library 폴더가 맞는지, 경로가 맞는지 확인해주세요.
C:/Users/userpc/Documents/R/win-library/3.6/ 입니다
– 윈도우10 64bit가 맞는지 확인해주세요.
네 맞습니다.
무엇이 문제일까요

김영인 · 2020-04-29 10:30 오전

안녕하세요. 좋은 정보 공유 고맙습니다. 어찌어찌 KoNLP 설치가 된 것 같기는 한데, 이런 오류 메시지가 계속 뜹니다. 회사와 집에서 각각 Window와 맥을 쓰고 있는데 두곳 모두 같은 문제가 생기네요. 무엇이 문제일까요? 고맙습니다.

> library(‘KoNLP’)
Error: package or namespace load failed for ‘KoNLP’:
package ‘KoNLP’ was installed before R 4.0.0: please re-install it

    원동준 · 2020-05-02 4:03 오후

    저도 똑같은 오류가 생기는데 해결하셨으면 연락부탁드립니다..ㅜㅜ제발…
    (ehdwns0654@naver.com)

      박소진 · 2020-05-11 6:57 오후

      저도 같은 오류가 생기는데 혹시 해결되셨나요?ㅜㅜㅜ 되셨다면 연락부탁드립니다(tcr12346@naver.com

    김성진 · 2020-05-18 10:29 오후

    저도 같은 문제가 발생하는데 해결방법 아시면 저도좀 알려주세요 부탁드립니다.
    torms22@gmail.com

      박세린 · 2020-06-13 7:11 오후

      저도 이런 오류가 계속 발생하는데 방법아시면 알려주세요ㅜㅜ

      하유경 · 2020-06-24 12:25 오전

      으아 저도 같은 문제가 발생하고 있습니다 ㅠㅠ 정말 답답해서 죽겠어요 ㅠㅠ
      몇번을 프로그램을 깔고 지우고 파일을 여기저기서 다운받아서 라이브러리에 넣고 지우고 …
      마지막으로 뜨는 에러 메시지는 이겁니다 ㅠㅠ 제발 알려주세요 ㅠㅠㅠ…
      에러: package or namespace load failed for ‘KoNLP’:
      package ‘KoNLP’ was installed before R 4.0.0: please re-install it

강경숙 · 2020-05-20 9:04 오후

https://cran.rstudio.com/bin/windows/Rtools/
Installing package into ‘C:/Users/kangk/OneDrive/문서/R/win-library/4.0’
(as ‘lib’ is unspecified)
Warning in install.packages :
package ‘KoNLP’ is not available (for R version 4.0.0)

여기저기 사이트 보면서 다 해봤는데 이렇게 계속 뜨는데 어찌해야할까요

도와주세요 · 2020-06-02 1:51 오후

install.packages(“…/path/to/package.tar.gz”, type=”source”, repos=NULL)따라쳐서 실행했는데..
‘C:/Users/2019A00306/Documents/R/win-library/4.0’의 위치에 패키지(들)을 설치합니다.
(왜냐하면 ‘lib’가 지정되지 않았기 때문입니다)
경고: 패키지가 잘못되었습니다 ‘…/path/to/package.tar.gz’
에러: 에러: 지정된 패키지가 없습니다
경고메시지(들):
In install.packages(“…/path/to/package.tar.gz”, type = “source”, :
패키지 ‘…/path/to/package.tar.gz’의 설치가 0이 아닌 종료상태를 가졌습니다

라고 뜹니다.. 어떻게 해야하나요..?

지나가던사람 · 2020-06-17 9:25 오전

현재 “KoNLP”는 업데이트가 중단된 상태로 R 4.0.0 이전버전까지만 사용이 가능합니다. 제작자께서 R에 맞춰서 업데이트한 버전이 아직 없어서요. 패키지 사용을 위해서는 4.0.0 이전 버전으로 사용하셔야 합니다. 저도 이런저런 방법을 다해봤지만 역시나 이 방법 밖에 없었습니다.

지나가던사람2 · 2020-07-08 9:01 오전

저도 3일동안 구글링하면서 헤매다가 아래사이트에서 도움을 얻어서 설치에 성공했습니다.
다만 사전 Install Package는 링크된 facebook에 나와있는 것 처럼 추가해주어야 합니다.
아무튼 현재 R4.02 버전을 설치한 다음 KoNLP 폴더를 복사해주고, R studio에서 스크립트
실행해주니 말끔하게 동작합니다.

https://r-pyomega.tistory.com/12

R이 뭔지도 모르던 사람이 3일만에 wordcloud2를 실행시켜 본 후 감동의 여운을 느끼면서
글을 남김니다……

Slot Online Terpercaya · 2020-09-01 4:42 오전

It’s really good but that’s how it is, this article is really useful and thank you to various friends, good luck for you, keep on sharing experiences and other things so everyone knows.

tmdk · 2020-09-07 4:28 오후

java.lang.StringIndexOutOfBoundsException: String index out of range: -1
at java.lang.String.substring(String.java:1967)
at kr.ac.kaist.swrc.jhannanum.plugin.SupplementPlugin.PlainTextProcessor.SentenceSegmentor2.
SentenceSegmentor2.doProcess(SentenceSegmentor2.scala:68)
at kr.ac.kaist.swrc.jhannanum.hannanum.
Workflow.analyzeInSingleThread(Workflow.java:835)
at kr.ac.kaist.swrc.jhannanum.hannanum.
Workflow.analyze(Workflow.java:549)
at kr.pe.freesearch.jhannanum.comm.
HannanumInterface.SimplePos09(HannanumInterface.java:340

안녕하세요 R을 활용해 형태소분석으로 공부하고 있는데요
문장이 100자 이상될 경우 위에 에러가 발생하는것 같습니다.
혹시 어떻게 해결을 해야할런지요…R도 초보 자바도 잘 몰라서요
문의드립니다

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다